Instalation problem for beta3 on webhost4live

Developer
Jun 25, 2009 at 1:48 PM
Edited Jun 25, 2009 at 6:44 PM

I created site and ran it it using visual studio 2008 with no problems.  Upon uploading it to my Webhost4Life domain and setting the permissions for the App_Data folder I received an access error stating that access to App_Data/UserImages/Image was denied.  After opening a helpdesk item with WebHost4Life, they updated the code for the \SectionControls\HtmlEditor.ascx.cs

from:
string galleryPath = ResolveUrl("~/App_Data/UserImages/Image");

to:
string galleryPath = ResolveUrl("~/App_Data/UserImages/Image");
galleryPath = "D:\\hosting\\member\\Myhost\\MySite\\App_Data\\UserImages\\Image";

The code was updated to use absolute path instead.

This corrected the problem and I was able to run the site. 

I also discovered three additional issues:

1st - when you click on the spellcheck buton in the FreeTextBox editor, youreceive an error advising that netspell is not configured correctly.  How do I resolve this problem?

2nd - when using user self register, There is a problem with the Email sending I receive an error at

client.Send(mail);

 

I looked at the email code looks the same as the

send email for the contact form which is working correctly.  Any ideas as to why I receive an error for this form?

 3rd.  When I selected the insert picture from gallery icon while in edit mode of the FreeTextBox html editor,  the home page was opened instead of the image gallery.  How do I correct this proble?  It works correctly when running from my local host.

Jul 23, 2009 at 5:55 PM

Here is the fix for the issue. 

Change the line 14 in HTMLEditor.ascx.cs:

from --> string galleryPath = ResolveUrl("~/App_Data/UserImages/Image");

to --> string galleryPath = HttpContext.Current.Server.MapPath("~/App_Data/UserImages/Image");

PS: I haven't tried to run the app without these few lines, but they are repeats of the lines in FtbImageGalleryAdapter.cs.  It would seem that refactoring / code consolidation is in order here.

Aug 18, 2009 at 10:30 AM

Thanks for the answer! That solved the problem for me!